membandingkan tanggal pada PHP

cara membandingkan tanggal yang baik pada PHP adalah sebagai berikut

$tanggal = ‘2010-10-31’;

strtotime($tanggal) > strtotime(‘now’)

dengan script di atas maka perbandingan tidak akan berjalan , karena $tanggal bukan sebagai datetime , maka untuk bisa di bandingkan dengan baik maka

$tanggal = ‘2010-10-31 00:00:00’;

karena jika tidak di isi timenya maka perbandingan tidak bisa berjalan dengan baik pada xubuntu 13 saucy salamander dan php 5.5

install kompozer di xubuntu 13 saucy salamander

install kompozer on xubuntu

$ sudo apt-get install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libidl0 libnspr4 libnss3 libpango1.0-0 libpng12-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g

Download file di bawah dengan terminal

wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8~b3.dfsg.1-0.1ubuntu2_i386.deb

install semua yang telah di download tadi dengan perintah

sudo dpkg -i kompozer*.deb

jika terjadi broken dependencies

sudo apt-get install -f

kompozer 64 bit system

$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb

untuk instalasi 64 bit sama dengan 32 bit 😀

voilaa 😀